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1 About Spaced Repetition

Anki is a free flashcard program based on an idea called “spaced repetition.”
Rather than spending time studying all of your flashcards every day, even the
ones you know very well, you instead review only those cards that you are just
about to forget. In this way, you can learn information and retain it with the
least effort possible.

Further reading on spaced repetition:
http://ankisrs.net/docs/manual.html#_introduction

http://www.wired.com/medtech/health/magazine/16-05/ff_wozniak

2 Installing Anki

1. Go to http://ankisrs.net.

2. Select your operating system.

3. Click the “download latest release” link. Install Anki as you would nor-
mally install any piece of software on your computer system.

Note: Anki can also be used on many mobile devices, on a flash drive, or on a
network drive. For further information, see 9: Anki on the Go.

3 Adding Content

There are three ways of adding content to Anki:

• Downloading a “shared deck” from the Internet.
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• Creating your own deck.

• Importing a deck (for example, one downloaded from Blackboard).

When you start Anki, you will see three buttons at the bottom of the screen:
Download, Create, and Import.

3.1 Downloading a Shared Deck from the Internet

A number of Anki users have created decks and shared them with other users.
These “shared decks” are stored on the Anki website. There are decks on a wide
variety of topics, including SAT vocabulary, the German chancellors, anatomic
terminology, and state capitals. Anki provides a convenient interface to search
for and select these decks. To download a shared deck:

1. Click the Download button or choose File → Download → Shared Deck.

2. Scroll through the list to find a deck you would like to download. By
default, the list is sorted by popularity, but you can change this by clicking
on the column heading that you want to sort by. Alternatively, you can
search for a deck by typing keywords in the Search box at the top.
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3. Select the deck you wish to download and click OK.

3.2 Creating Your Own Deck

To create your own deck from scratch:

1. Click the Create button and give your deck a name.

2. Click the green cross in the upper-left corner to begin adding cards.

3. Choose whether you want your cards to be reviewed front to back, back
to front, or both. To change from the default setting (which is front to
back only), use the button in the upper-right corner labeled Cards. You
will be able to change this setting for each card you add.

4. Type the question in the Front box and the answer in the Back box.

5. Add a tag using the text box at the bottom of the window. This will
help you keep your deck organized and make it easier to study subsets of
cards. If you want to add more than one tag, simply put a space between
the tags. Note that an individual tag cannot contain any spaces (i.e. use
“Chapter1”, not “Chapter 1”). This tag will be added to all cards you
enter until you change the tag.

6. When you are done entering each card, click the Add button or press
Ctrl-Enter (Command-Enter on a Mac).
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Note: Anki has a feature called Models, with which you can make things like
three-sided flash cards. This feature is complex but extremely powerful. If you
are interested in learning about models, take a look at the official documentation
at http://ankisrs.net/docs/CardLayout.html.

3.3 Importing a Deck

You might get a deck created by someone else from a source other than Anki’s
“shared deck” page. For instance, an instructor might post a deck on Blackboard
or a friend might email you a copy of his or her deck. To import a deck:

1. Click the Import button at the bottom of the screen or choose File →
Import. Give the new deck a name when prompted and click OK. In the
resulting dialog box, choose “Anki Decks (*.anki)” from the Files of Type
drop-down menu. Now find the location where you downloaded the deck
and double-click on the deck.

(If you aren’t sure where you downloaded the deck, look in your Downloads
folder. This folder can usually be found in your Documents folder, home
folder, or the folder bearing your username. It might also be on your
desktop. If you really can’t find it, try doing a search for the name of the
deck and noting the folder where it appears. In some browsers you can also
right-click on the icon for the file you just downloaded and choose Open
File Location; this will bring you directly to the folder it downloaded to.)

2. A dialog box will appear. Click the Import button. Anki will tell you the
cards were successfully imported, and you will see the new cards in your
deck.
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4 Changing Settings and Preferences

Anki is a highly customizable program. Most of the time you can probably
stick with the defaults, but there are a few options you might want to change.
There are three places where you can change Anki’s settings: study options,
preferences, and deck properties.

4.1 Setting Study Options

4.1.1 New Cards Tab

1. New Cards/Day: This sets the number of new cards you see each day.
The default is 20—if you set it higher, be prepared for a lot of reviews. If
you are ever feeling overwhelmed by too many reviews in a deck for which
timing is not critical, you might want to temporarily set this option to 0
to give yourself a break. If you’re doing Anki for a class and need to keep
to a particular schedule, you might adjust the number of new cards from
time to time so that you can keep on pace with the rest of the class.

2. Display Order: There are two drop-down menus. The first menu controls
what order you see new cards in. The default is Show New Cards in Order
Added, which should be used if the person who created the deck wanted
the cards to be learned in a specific order; in other cases, you usually want
random order. The second menu controls at what point in your review
session you see new cards. The default is Spread New Cards Out Through
Reviews; with this option, you will see new cards mixed in with cards you
have already seen. If you prefer to see your new cards all at the beginning
or end of a review session, you can change this setting.

3. Selective Study: This lets you select only certain parts of a deck to
study. See the section Selective Study (6: Managing Your Deck).

4.1.2 Reviews Tab

1. Max Failed Cards: This allows Anki to display cards you have answered
incorrectly earlier than usual in your review session if there are a lot of
them. Unless you have a good reason to change it, the default of 20 works
well.

2. Display Order: There are two drop-down menus. The first menu controls
whether you first see cards you know best or cards you know worst. The
default (cards with the longest intervals first) helps keep you motivated
because you see the easiest cards first. The second menu controls how
long Anki waits before showing you failed cards. This is another setting
that’s probably best left at the default unless you have a good reason to
change it.
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4.1.3 Timeboxing Tab

This tab lets you limit the amount of time you spend reviewing during each
study session, either by specifying a maximum number of minutes or a maximum
number of cards. It’s especially useful if you’re facing hundreds of reviews after
returning from a long break and you want to spread them out.

4.2 Changing Preferences

Preferences affect your reviews and the general behavior of Anki across all decks.
You may adjust them while any deck or no deck at all is open. You can change
preferences at Settings → Preferences; they include general interface, save, and
backup settings. For more information, see
http://ankisrs.net/docs/Preferences.html.

4.3 Changing Deck Properties

Deck properties affect only one deck. Besides synchronization options, they are
mostly technical settings for changing the spaced repetition algorithm. They
can be accessed by opening the deck you want to modify and choosing Settings
→ Deck Properties. For more information, see
http://ankisrs.net/docs/DeckProperties.html.

4.4 Further Reading

5 Studying

5.1 Reviewing Cards

1. Start Anki, then click the Open button next to the deck you wish to study.
Click the Start Reviewing button.
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2. At the top of the screen, you will see the front of the card. Determine
your answer or response. Click Show Answer or press the spacebar. The
back of the card (the answer) will appear at the bottom of the screen.

3. Rate yourself on how well you knew the answer.

4. Continue reviewing cards until you finish all cards that are due. You will
see a brief summary of your progress. Click Finish to go back to the main
screen, where you can select another deck to review or close the program.

5.2 Rating Cards

Anki provides four “eases,” or rating levels: Again (1), Hard (2), Good (3),
and Easy (4). On cards seen for the first time, the same levels are labeled as
Again(1), Good (2), Easy (3), and Very Easy (4). To select a rating, you sim-
ply click one of the buttons or type the corresponding number (1, 2, 3, or 4).
Pressing the spacebar is a shortcut that always selects “Good.”

Note: If you rate a card incorrectly, you can press Ctrl-Z to undo your rating
and see the card again.

5.3 The Status Bar

The status bar is located at the bottom of the screen when you are in a review
session. There are four parts of the status bar:

• The Remaining Cards queue, which shows you how many cards you have
left to study. Anki maintains three “stacks” of cards: 1) a stack of cards
you have answered incorrectly in the current session and need to see again,
2) a stack of cards that are due to be reviewed today, and 3) a stack of
cards that are new today.

• The ETA, the amount of time that Anki estimates it will take you to
complete your reviews if you continue at your current pace.

• The performance bars, which show the percentage of cards you have an-
swered correctly; the top bar shows the percentage of all cards you have
answered correctly today and the bottom bar shows the percentage of
mature cards you have answered correctly over the life of the deck. (The
bottom bar is a good indicator of whether you are rating cards appropri-
ately: it should be between 85 and 95 percent.)

• The timer, which shows the time you have spent answering the current
question. You should aim to answer each question within ten seconds; if
you cannot, it is probably better to fail it and review it again later in the
session.
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5.4 Cramming

Anki’s cram feature allows you to study for a test or quiz by studying all of the
relevant cards one last time before the test, not just the cards that happen to
be due that day.

1. Determine the tag or tags that you wish to cram (e.g. “Quiz2”). If the
cards you want to cram are not tagged, go into the deck browser and tag
the cards you want to review. (See 6: Managing your Deck.)

2. Make sure all the cards you want to review are unsuspended. Anki au-
tomatically “suspends” cards that it notices you are having trouble with
(known as “leeches”), taking them out of the rotation of normal reviews.
You will not see these cards in your cram (and thus not know the informa-
tion on them when it’s time to take the test) unless you unsuspend them
first. To unsuspend cards, open the deck browser and select “Suspended”
from the Filter drop-down in the upper-right corner. Now select the cards
that you wish to unsuspend and choose Actions → Toggle Suspend.

3. Choose Tools → Cram and type the tags of all the cards you want to
review, separated by spaces. You can also choose what order you want to
see the cards in.

4. Click OK to begin the cram session. You will know you have entered the
cram session because the number of cards in the status bar will change.

5. When you have reviewed all cards included in the cram, you will be re-
turned to the normal view; you can now review any cards that are still
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due. To cancel the cram before completing all cards, you can click the
clock icon (Study Options) on the toolbar, or simply close the deck.

Note: Reviewing cards in a cram session affects the scheduling of future reviews,
just like in a normal review session.

6 Managing Your Deck

After you have been using Anki for a while, you will eventually need to perform
tasks like editing cards, tagging items, studying only certain parts of a deck
(selective study), dealing with leeches, and suspending cards. Your primary
tool for managing your deck is the deck browser. You can open the browser by
choosing Edit → Browse Items or pressing Ctrl-F.
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6.1 Editing Cards

To edit a card, choose Edit → Current Fact while the card is displayed or press
Ctrl-E. Alternatively, you can open the deck browser and search for the card.
Make your changes and click Continue Reviewing (or close the deck browser).
Making the change once is sufficient: if you are changing a front to back card
and there is a matching back to front card, both will be updated simultaneously.

6.2 Tagging Items

Although it is best to add tags as you are creating cards, you may add them
later if you need to. You can easily tag cards from the deck browser, but there is
one trap: if you wish to add tags to more than one card simultaneously, selecting
all the cards and changing the Tags text box at the bottom of the screen will
only change one card—to change them all, you must instead choose Actions →
Add Tags.

6.3 Selective Study

Anki provides an easy way to choose only certain cards to study. For example,
let’s say you downloaded a deck containing information about all the countries
in the world and you needed to know just the information about Africa by
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the end of next week. Provided that the author of the deck has tagged cards
properly, you can easily select just the category you want. (If the author has not
tagged cards, you can always go into the deck browser and tag cards yourself.
See Tagging Items, above.) To change selective study options:

1. Open the deck and go to Study Options. It should be the first thing you
see upon opening the deck.

2. Go to the New Cards tab. Under the Selective Study section, click the
Change button.

3. Use the options to select tags of cards you want to see, tags of cards you
don’t, or both. Once you’ve selected the cards you want to see, choose
whether you want this setting to apply to cards you’re already studying,
new cards, or both.

4. You can return to this dialog box to choose which cards you want to study
at any time. For instance, once the test about Africa has passed, you can
select cards for the next region you want to learn about, or all other cards.

6.4 Dealing with Leeches

A “leech” is defined as any card that you have answered incorrectly 16 times.
Anki automatically suspends leeches and tags them with “Leech.” Anki does
this to make your learning more efficient: sometimes it is better to let a card
that you are having particular difficulty with sit for a while. (If you are learning
this information for a test, you’ll want to make sure you unsuspend it sometime
before the test, perhaps when you’re using the cram function.) When you’re
ready to unsuspend a leech and study it again:

1. Open the deck browser.

2. Select “Leech” from the Filter drop-down menu in the upper-right corner.
A list of all current leeches will appear.

3. Select any leeches you wish to begin reviewing again and choose Actions
→ Toggle Suspend.

4. Delete the “Leech” tag from these same cards by choosing Actions →
Delete Tags and typing Leech.

6.5 Suspending Cards

Anki creates suspended cards whenever it marks cards as leeches, but sometimes
you may want to suspend a card yourself. For instance, you might not want
to study a particular card right now, but prefer not to delete it. To suspend a
card:

1. If you are reviewing and have the card you wish to suspend on-screen,
simply choose Edit → Suspend Card or press Ctrl-Shift-S.
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2. If the card you want to suspend is not currently displayed, open the deck
browser, find the card, and choose Actions → Toggle Suspend or click the
pause icon on the toolbar.

Note: If you want to set aside a large chunk of cards, you should use selective
study instead of suspending them.

6.6 Additional Features

Anki includes two additional features for deck management: marking and bury-
ing. Marking a card tags it with “Marked,” making it easy to find later. (Just
select “Marked” from the Filter drop-down in the upper-right corner of the deck
browser.) This can be useful for noting that you need to modify a card later.
Burying a card makes it disappear until you next open the deck.

6.7 Merging Decks

If your instructor has created an initial deck and then wants you to add more
cards to it, you’ll need to merge the two decks (old and new). Here’s how:

1. Download the Anki file containing the cards you want to add to your
current deck.

2. Open the current deck in Anki and choose File → Import. Browse to
the location where you downloaded the deck. (See “Importing a Deck” in
section 3 if you can’t find the location.)

3. Select the deck, then choose “Anki Deck” from the drop-down menu. Click
Open.

4. Click the Import button. Anki will tell you importing is complete.

7 Tracking Your Work

7.1 Deck Statistics

The Deck Statistics sidebar for a given deck can be viewed by choosing Tools
→ Deck Statistics. Some of the more interesting statistics are:

• Total Number of Cards: This tells you how many cards are in the deck.
This can be useful if you need to compare two versions of a deck or make
sure that a deck has copied properly.

• Card Maturity: This tells you the percentage of cards that are mature
(have an interval of over 21 days), young (interval under 21 days), or
unseen (new and not yet reviewed).

14



• Correct Answers: This tells you what percentage of cards you have an-
swered correctly during reviews. You should aim to get 85-95% of mature
cards correct. Note that this information is also available by hovering over
the colored bars on the status bar.

• Recent Work: This tells you how many cards you have reviewed in the
given period of time (“reps”), as well as how many days out of the period
you have studied.

• Average Daily Reviews: This tells you how many cards you have re-
viewed per day, on average, in the given period. This allows you to see
trends in the number of cards you have had to review.

There are even more statistics:
http://ankisrs.net/docs/CardStatistics.html.

7.2 Graphs

Sometimes a graphical representation is an easier way to view your progress
than the deck statistics. To view graphs, choose Tools → Graphs. There are
eight available graphs:

• Due: This shows you how many cards will be due at the end of each
coming day. (Anki considers 4 AM the start of a new day since you may
stay up late studying.)

• Reps: This shows you how many cards you have reviewed on each past
day, broken down into new, young, and mature cards. Blank spaces rep-
resent days on which you did not review.
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• Review Time: This shows you the time you have spent reviewing each
day.

• Added: This shows you the number of cards that have been added to the
deck each day.

• First Answered: This shows you the number of new cards you have
looked at each day.

• Cumulative Due: This shows you how many cards will be due on a
given date in the future if you don’t do any more reviews.

• Intervals: This shows you the number of cards with different intervals
(the length of time from when you studied the card until you need to
review it again).

• Eases: This shows you how many cards you gave an Again, Hard, Good,
or Easy rating to in the three categories of new cards, young cards, and
mature cards.

You can select a time period for each graph from the drop-down box underneath
the graph. If you do not wish to see one or more graphs, click the Show/Hide
button and choose accordingly.
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7.3 Printing Graphs

Your instructor might ask you to print graphs to show that you have been
studying regularly. Anki does not provide a graph-printing feature, but you
can easily print a copy of the graphs window. The process depends on your
operating system.

7.3.1 Windows

1. Decide which graphs you want to see on your printed copy. Hide graphs
using the Show/Hide button as necessary to display just the graphs you
want to print. You can resize the window if they don’t fit.

2. Make sure the graphs window is active (click on its title bar) and press
Alt-Print Screen. (The Print Screen key is usually in the upper-right
corner of your keyboard, near the scroll lock and number lock keys, and
is sometimes abbreviated Prt Sc or Print Scr.)

3. Open Paint (choose Start → All Programs → Accessories → Paint) and
paste the contents of the clipboard. (You can also use Microsoft Word.)

4. Send the image to your printer.

7.3.2 Mac OS X

1. Decide which graphs you want to see on your printed copy. Hide graphs
using the Show/Hide button as necessary to display just the graphs you
want to print. You can resize the window if they don’t fit.

2. Press Command-Shift-4. You’ll get a funny little icon with numbers on it.
Press the spacebar, then click on the Anki window.

3. A new image will be created on your desktop, called Picture 1. Print this
image.

7.3.3 Linux

These instructions are for GNOME in Ubuntu; other distributions will probably
be slightly different.

1. Decide which graphs you want to see on your printed copy. Hide graphs
using the Show/Hide button as necessary to display just the graphs you
want to print. You can resize the window if they don’t fit.

2. Select the Anki window and press Alt-Print Screen. (The Print Screen key
is usually in the upper-right corner of your keyboard, near the scroll lock
and number lock keys, and is sometimes abbreviated Prt Sc or Print Scr.)
You’ll get a window asking you whether you want to save the screenshot
or copy it to the clipboard. Click Save and save the file.

3. Open the file that you just saved and print it.
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7.4 Card Statistics

Anki can also display statistics about individual cards, such as when the card
was added and last modified, its current ease, and the average time it takes you
to answer the card. Normally, this information is more technical than you need,
but if you’re curious about a specific card, you can look at card statistics by
choosing Tools → Card Statistics while the card is displayed. (This info is also
shown in the lower-right corner of the deck browser.)

8 Backing Up Your Work

Backing up your work is always a good idea, but it is especially important with
Anki. If you lose your Anki deck, you will not only lose the actual cards in the
deck, but also all of your valuable scheduling information, meaning that you’ll
have to re-learn every card from scratch. You will want to regularly copy your
Anki data files to an external device so that if your system crashes, you will be
able to restore your data.

Note: If you synchronize to AnkiWeb (see section 9), that is usually a sufficient
backup, and only section 8.4 is likely to be of use to you.)

8.1 Backing Up Your Work with AnkiBackup

Using a simple program called AnkiBackup, you can back up your decks with a
couple of clicks. The process depends on your operating system:

8.1.1 Windows

1. Download the executable Windows version of AnkiBackup from
http://thetechnicalgeekery.com/anki/.

2. Run the program by double-clicking it. (If you get a warning that the file
is not digitally signed, it’s okay to click Run.)

3. Press Enter to start the backup. A new folder named “AnkiBackup” will
be created on your desktop.

4. Copy this folder to somewhere other than your main hard drive (a flash
drive, a network drive, a location on the Internet, etc.)

5. Repeat steps 2-4 regularly, preferably at least once a week. If the Anki-
Backup folder is still on the desktop from the previous week, you’ll get a
prompt asking if you want to overwrite it—just press Enter.
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Note: If you can’t get the program to run, you can install Python and then
download and run the source code. Further instructions are under the second
bullet on the website.

8.1.2 Mac OS X

1. Download the Mac version of AnkiBackup from
http://thetechnicalgeekery.com/anki/.

2. Run the script by double-clicking it.

3. Press Enter to start the backup. A new folder named AnkiBackup will
be created on your desktop. The program window will say “[Process
completed].” Close the window.

4. Copy this folder to somewhere other than your main hard drive (a flash
drive, a network drive, a location on the Internet, etc.)

5. Repeat steps 2–4 regularly, preferably at least once a week. If the Anki-
Backup folder is still on the desktop from the previous week, you’ll get a
prompt asking if you want to overwrite it—just press Enter.

8.1.3 Linux

These directions are using Ubuntu 11.04 with the Nautilus file manager, but
other distributions should be similar.

1. Download the AnkiBackup Python script from
http://thetechnicalgeekery.com/anki/.

2. Set the executable bit on the script, which can be done either with the
terminal command “chmod +x [filename]”, where [filename] is the location
of the script, or (if you’re using Nautilus and GNOME) right-clicking
on the file, choosing Properties, and going to the Permissions tab. The
checkbox is labeled “Allow file to run as program.”

3. Run the script by double-clicking it. Press Enter when prompted.

4. A folder called “AnkiBackup” will be created on your desktop. Copy this
folder to somewhere other than your main hard drive (a flash drive, a
network drive, a location on the Internet, etc.)

5. Repeat steps 3 and 4 regularly, preferably at least once a week. If the
AnkiBackup folder is still on the desktop from the previous week, you’ll
get a prompt asking if you want to overwrite it—just press Enter.

If you get errors, your version of Anki is probably installed in a different lo-
cation. Try finding your Anki folder through the directions in “Backing Up
Your Work Manually” (below), then rerunning the script, using i to specify
advanced options, and entering the path. Also, please contact the author of the
script (email webmaster@thetechnicalgeekery.com) so that AnkiBackup can
be updated to work properly in the future.
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8.2 Backing Up Your Work Manually

Finding the Anki data files is often easier said than done—it depends on your
operating system, your version of Anki, and maybe even the way your computer
was set up. For this reason, if you can, it’s usually easier to use the AnkiBackup
program. If for some reason you cannot or don’t want to, here are some places
where your Anki decks might be stored:

• ˜/.anki/decks

• ˜/Anki

• ˜/Documents/Anki

• ˜/My Documents/Anki

The ˜ represents your home directory, which is often labeled with your name
or “Home Folder” and should be accessible from somewhere in your operating
system menus or file browser. The exact location depends on your operating
system but is often one of:

• C:\Documents and Settings\[your username]

• C:\Users\[your username]

• /home/[your username]

• /Users/[your username]

If you still can’t find the location where your Anki decks are stored, you can try
searching for them:

1. Find the name of one of your decks. This will be what is displayed in the
deck list that appears when you open Anki or in the title bar (the line at
the top of the window) while reviewing a deck.

2. Use your operating system’s search feature to search for “[deck name].anki”.

3. Find the location of that file, which will usually appear next to the filename
when you hover the mouse over the file, or sometimes when you right-click
the file and choose “Open File Location.”

4. That folder will contain your Anki data.

Once you have located the place where Anki stores your data, copy the entire
contents of that folder to a flash drive or location on the Internet. Repeat this
process frequently, preferably at least once a week.
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8.3 Restoring a Backup

If you get a new computer or your computer crashes and you need to restore a
backup, here’s how to make Anki recognize your old decks again:

1. Install Anki on the computer if it is not installed already.

2. Copy your most recent backup to your desktop. (If your old computer
still works, make a backup and copy it to the new system.)

3. Locate the place where Anki stores its data, following the directions in
section 8.2. Copy the files contained in your most recent backup folder to
that location.

4. In Anki, choose File → Open. Select the deck you restored and click the
Open button. Repeat this step for each deck if you have more than one.

8.4 If a Deck is Damaged

Occasionally something will happen to an Anki deck and it will no longer work
properly. Maybe the deck file was damaged by a problem with your hard disk, or
maybe you just accidentally deleted a bunch of cards. Anki creates and stores
a backup copy of your deck every time you open it. If your hard drive and
computer are still working fine but your deck is damaged, you can restore from
one of these copies.

Note: This feature is not a substitute for regular backups—it will not save you
if your whole computer crashes!

To restore from one of Anki’s backup copies of a deck:

1. Start Anki and choose Settings → Preferences.

2. Select the Saving tab and click the Open Backup Folder link.

3. Find the most recent backup file of the deck you need to restore. (The
filenames are long and filled with odd characters, but you should still be
able to tell which deck is which.) Copy this file to your desktop.

4. Return to Anki, close the Preferences dialog box, and choose File→Open.
Browse to your desktop and open the copy of your backup file.

5. To see if this backup fixes the problem you were having, try it out—review,
open the deck browser and search for cards, and so on. If the backup isn’t
what you wanted, go back to step 3 and try a copy with an earlier date.

6. Once you have determined that the deck is okay, choose File → Save As.
Browse to the Anki data location (if you don’t know where it is, see the
information in “Backing Up Your Work Manually,” above) and save the
file with the deck’s original name. If the old, damaged deck is still there,
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Anki will ask you if you want to overwrite it; since the new copy is the
good one, choose Yes.

9 Using Anki On The Go

In addition to the version of Anki you use on your computer (hereafter referred
to as the “desktop version”), there is an online version of Anki that can be
used from any computer with an internet connection. There are also Anki apps
available for most popular smartphones. While these mobile versions of Anki
are not ideal for adding content or managing your decks, they are excellent
for getting some reviews done when you’re away from your computer. The
developer of Anki provides a server and synchronization system so that you can
review on any device and keep all of your devices up to date.

9.1 Setting up Synchronization

1. Go to http://ankiweb.net/.

2. Type your email address and a password and click the Sign Up button.
You will be asked to check your email for a confirmation message.

3. Check your email and click the confirmation link. You will be logged into
your new AnkiWeb account.

4. Open the desktop version of Anki.
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5. Go to Settings → Preferences and click the Network tab.

6. Type in your newly created username and password.

7. Select the Sync on Program Open/Close and Disable Sync when Deck
Moved options. Unselect all the others and click the Close button.

8. Open the deck you wish to synchronize. (If you want to sync multiple
decks, choose one to start with.)

9. Choose Settings → Deck Properties and click the Basic tab.

10. Check “Synchronize this Deck with AnkiWeb.” Click the Close button.

11. Choose File → Sync. Anki will upload your deck to the server.

12. Restart Anki.

13. Repeat steps 8–12 for other decks you wish to synchronize.

14. Visit AnkiWeb to be sure that your decks are there.

15. If you ever download or create any new decks, don’t forget to repeat these
steps for them so that Anki knows you want to synchronize them as well.

9.2 Using AnkiWeb

1. To begin reviews, browse to http://ankiweb.net/ and log in if necessary.

2. Click the Review button at the top of the page if you do not immediately
get the reviewing screen. Anki will pick a deck for you to start with. You
can click the Decks button to select a different deck to study.

3. You can review just as you would on the desktop version. When you are
done, click the Decks tab to select another deck to study or the Logout
button if you are done.

9.3 Using the Anki iPhone App

The iPhone app for Anki costs $25, which is a bit steep, but the app is conve-
nient and well-designed. (The author of Anki works on the program full time
and then releases the desktop version for free, so he needs to charge a fair
amount for the iPhone app to make a living.) If you cannot afford the app, you
can always visit the AnkiWeb website on your iPhone, but the app looks and
works much better and doesn’t require internet access to review.

To set up Anki for the iPhone:

1. Make sure that you have completed the step “Setting up Synchronization”
(above).
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2. On your iPhone or iPod Touch, open the App Store and search for “Anki.”
The app is called “AnkiMobile Flashcards.” Pay for, download, and install
the app as you would any other app.

3. Open the Anki app. Click the wrench icon in the upper-right corner of
the screen and choose Syncing. Enter your username and password.

4. Click the back button in the upper-left corner twice to return to the decks
list.

5. Click Add/Export, select Add From AnkiWeb, and select the deck you
wish to add to your device. Repeat this step if you have more than one
deck to add.

6. You can now review your deck as you would on the desktop version—tap
the screen to show the answer and then touch a rating button. There are
many useful interface options that can be personalized as you desire; look
through the options page to learn about them.

7. Before and after reviewing on your iPhone, be sure to push the Sync
button to copy the changes you’ve made to and from other devices. If you
don’t do this, it is possible that your decks may get out of sync, which is
difficult to correct.

Note: If you want to review somewhere without internet access, just remember
to sync before you leave, while you’re still connected. If you don’t, you may end
up having to redo reviews that you’ve already done on another device. Don’t
forget to sync the device again when you get back. If you do forget and it causes
a problem, see section 9.6 below.

9.4 Using Other Versions of Anki

There are versions of Anki for many other handheld devices, including Android.
See the following website for details:
http://www.ankisrs.net/#maemo.

9.5 Synchronizing Between Two Computers

If you use multiple computers instead of or in addition to mobile devices, you
can easily synchronize your decks between those as well. First, if you have
not already done so, set up an AnkiWeb account and add your decks to it, as
described in section 9.1. Then follow these steps:

1. Install Anki on the second computer.

2. Choose Settings → Preferences, click the Network tab, and enter your
AnkiWeb username and password.

3. For each deck you wish to download, choose File→ Download→ Personal
Deck and select the deck.
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4. Your decks will now be synchronized between computers. Don’t forget
to close Anki or run File → Sync before moving to another computer or
device.

9.6 Synchronization Problems

If you neglect to sync on one device and begin reviewing on another, you may
experience problems. Most commonly this comes in the form of a prompt when
syncing, which asks you to “keep local” or “keep remote.” If you get this
message, you should make your choice based on whether you most recently re-
viewed on your current device (local) or on another device (remote). The ability
to merge decks and automatically fix problems like this will be coming in the
next version of Anki.

Rarely, a worse problem may happen, where the review counts will be different
on different devices, you see cards you’ve already reviewed, and syncing repeat-
edly doesn’t help. If this happens to you, look at this link:
http://tinyurl.com/ankifaq#_reviews_changes_don_8217_t_seem_to_be_

syncing.

9.7 Using Anki on a Flash Drive or Network Drive

If you don’t have your own computer, you can put Anki on a flash drive or
network drive and use a public computer to study. See the instructions at:
http://tinyurl.com/ankifaq#_can_i_run_anki_from_a_flashdrive.

10 How To Set Up Anki For Your Students

10.1 How to Get Anki Decks to Your Students

You have three basic options for getting your students the information you want
them to study:

1. Give them the information (either all at the beginning of the semester or
as you go along) and have them enter it into Anki themselves. This option
involves duplicated effort, but having each student enter the information
can aid learning, and you don’t have to deal with creating and distributing
a deck.

2. Make an Anki deck containing all the information you want your students
to study for the entire semester and have them download it one time,
right at the beginning of the semester. You should tag each chapter’s
information so that students can use the selective study feature to study
each chapter as you are covering it in class. This option requires you to
plan ahead, but it is easy for the students and you don’t have to think
about it once everything is set up.
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3. Create an initial deck containing some of the cards you want your students
to learn, have them download and begin reviewing it, and then issue more
smaller decks that they can import and add to the original deck as the
semester goes on. This is somewhat difficult to organize, but it allows you
to continue working on the deck throughout the semester.

Before attempting to set up Anki for your students, make sure you read the
other sections of this documentation.

10.2 Importing Data Into Anki

You may already have a list of vocabulary items or other material that you wish
to convert to Anki cards. To import data into Anki, you need to create a file of
tab-separated information. The easiest way to do this is to paste or otherwise
transfer it into a spreadsheet, using a program such as Microsoft Excel.

1. Open Excel and create a new document.

2. Paste the questions into column A and the answers into column B. If you
want, you can put tags into column C. (If you already have a file in another
format, such as a Microsoft Word document, it may be more efficient to
try importing or opening it in Excel.)

3. Copy the cells containing the information you wish to import.

4. Open a text editor, such as Notepad or TextEdit, and paste the data into
a new file.

5. Choose File → Save As. Select UTF-8 encoding and save it as a text file.
(If you are using a Mac with the TextEdit program, before going to Save
As, you will need to choose Format → Make Plain Text.)

6. Open Anki and create a new deck. (If you want to add cards to an existing
deck, open that deck and start step 7 from there.)

7. Choose File → Import. Make sure that the drop-down box in the lower-
right corner says “Text separated by tabs or semicolons.” Then browse to
the location where you saved the text file.

8. Just like when you create a deck from scratch in Anki, you have the
opportunity to create cards that will be reviewed front to back (forward),
back to front (reverse), or both. The button to change this option is
located in the upper-right corner of the dialog box.

9. Click Import. Anki will tell you how many cards were imported and
whether there were any errors. If you had errors, you made a formatting
mistake—use the error message to determine what you did wrong and
correct the mistake, then save it and retry from step 7. Otherwise, you’re
done.
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10. If you later make a change to an item and want to update the card in
Anki, follow these steps to import the document again, but in step 9, click
the Update button instead of Import.

10.3 Exporting a Deck

If you plan to have students download your deck from a location other than the
Anki shared decks database (such as a course management system like Black-
board), you’ll need to export your finished Anki deck so that your students
can download it. (Note: If you want to post to the shared decks database, see
section 10.4. To do this:

1. From the deck you want to export, choose File → Export.

2. Select “Anki Deck (*.anki)” from the drop-down menu. You can limit
the exported deck to specific tags if you want. Do not include scheduling
information.

3. Click Export. Browse to the location where you’d like to put the file and
type a name in the Name text box. Anki will take a moment to make
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a copy of your deck with the options you specified, then a message like
“1000 cards exported” will appear in the status bar momentarily.

4. You can now post this deck to Blackboard or use any other method to get
the deck to students. Using this file, students can create a new deck or
merge the cards into an existing deck.

10.4 Uploading a Deck to the Shared Decks Database

1. Create your deck. Make sure it’s exactly how you want it; although you
will be able to update the shared deck after you have submitted it, if
people have already downloaded it they won’t see the changes. So it’s
wise to get it right the first time.

2. If you don’t already have an AnkiWeb account, create one. (See section
9.1.)

3. Log in to your AnkiWeb account and select the More tab, then choose
Share Decks and Plugins.

4. Click the “here” link. Enter a title and a description. You can also enter
some tags to make it easier for people to find your deck—for instance, if
your deck was about geography, you might write “geography,” “maps,”
and “world.” Each tag should be one word, separated from the next by a
space.

5. Open the deck in Anki and choose File → Export.

6. From the drop-down menu, select “Packaged Anki Deck (*.zip)”. Limit
the export to specific tags if you need to.

7. Click Export. A window will open, displaying a zip file and a README
file. Drag the zip file to your desktop and close the window.

8. Return to the AnkiWeb website and click the Choose File button. Browse
to your desktop and select the file.

9. Make sure all the information is correct and click the Upload button.

10. To update or delete the deck in the future, log into your AnkiWeb account,
click the More tab, choose Share Decks and Plugins, and then click the
appropriate button next to the deck you wish to modify.

Note: If you don’t log in to your AnkiWeb account in some time (three months
or more), your account may be deleted. If this happens, you will lose control
of your shared decks, so if you don’t use the account regularly for yourself, put
a reminder on your calendar to log in every so often. If you do lose control of
your decks, you can probably post on the Anki forums (see section 11) and ask
to have your account reinstated.
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10.5 Settings

There are some settings you might need to have your students change:

• If you have added cards in a particular order so that they match the order
the class goes in, students need to select the “Show New Cards in Order
Added” option on the New Cards tab of Study Options.

• You might want to have students study a certain number of new cards per
day to make sure they get through the deck by the end of the semester.
This option is on the New Cards tab of Study Options.

10.6 Good Practices when Creating a Deck

• Split up information into small bits. For example, if you wanted your
students to memorize the Gettysburg Address, making a question that
asked “What is the text of the Gettysburg Address?” would be a bad
idea—if a student forgot any part of the entire text, he or she would get
the whole question wrong, leading to great inefficiency and frustration.
Instead, you should ask smaller questions, such as “What phrase comes
after ‘Four score and seven years ago. . . .’”

• The cloze button can be very helpful in developing focused questions. To
use this button, enter a sentence or phrase in the Question box, select a
word or words you want to have your students fill in, and click the Cloze
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button (which looks like [. . . ]). The highlighted words will be automat-
ically removed from the front of the card and the full sentence will be
placed on the back.

• Add tags to all your cards. Most importantly, add a tag for any set of
questions that will be on a test, so that students can easily cram them.

• Make sure questions are unambiguous.

• Keep formatting parallel. Develop one way to ask similar questions and
use it every time you add a question of that type.

• Keep an open mind about phrasing questions. For example, instead of
writing “What date did [some event] happen?” repeatedly, consider cre-
ating cards that ask students to identify the relationships amongst events.
You could ask students which of two events came first or which historical
figure is associated with a given event. Remember that many different
kinds of questions can be made to fit the flashcard format.

11 More Information

The Anki website has a complete manual with more technical details, introduc-
tory videos, a FAQ, and a help forum. Visit http://ankisrs.net/ and click
the Documentation and Help Forum buttons to access them.
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